Chez oim, forum libreChez oim, forum libre

favicon Google Recherche avancée  

PRISM

Forum certifié NSA, PRISM2013.

Toi, le troll, le raciste, l'intolérant, passe ton chemin.
Ce forum défend la liberté d'expression, mais rappelle toi que celle ci n'autorise pas tout.



Pages: 1 ... 6 7 8 [9]   En bas

Auteur Sujet: Tuto Windows : Installez votre serveur DNS avec Unbound et oubliez les blocages  (Lu 10069 fois)

Jacky

  • Orateur balbutiant
  • Hors ligne Hors ligne
  • Messages: 13

Bonjour,
Espérant apporter une modeste contribution, je vous indique ce qui m'est arrivé, sur mes problèmes d'installation.
Depuis pusieurs mois  mes installations ne fonctionnent pas ou mal sur diverses machines de mon réseau. Machines en Windows 7, 7 pro, en x86 et en x64.
Une seule machine en x86 fonctionne sans problème.
j'ai donc cherché différents paramètres et/ou mises à jour....etc
modifications et adaptations des fichiers "named.cache" et "service.conf".....
Enfin j'ai trouvé.
Ces fichiers sont ouverts et/ou modifiés en ouvrant (pour moi..) avec le bloc-note de windows.puis j'enregistre ou enregistre-sous.
Il s'avère que mon bloc note sauve à la norme "UTF-8" (encodage), soit par exemple le fichier "service.conf" mais en Utf-8 et là ça ne fonctionne pas.
Je choisis "enregistrer-sous .. mais je choisis "encodage ANSI" et là..tout fonctionne.
J'ai donc fait le même sur toutes mes machines et tout est OK... :).

 :jw:
IP archivée

maximus23

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.641
  • Grand chevalier du mot de passe
      • ®Smf® Solutions

Bonjour,

Pour éditer les fichiers on utilise un éditeur digne de ce nom comme notepad2++ et là il n'y aura jamais aucuns soucis pour l'édition et l'encodage des fichiers programmés.

:)
IP archivée
Amitiés et à bientôt...
Have a nice day...

JCFM

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.054
  • Choléra officiel chez oim !

Pour éditer les fichiers on utilise un éditeur digne de ce nom comme notepad2++ et là il n'y aura jamais aucuns soucis pour l'édition et l'encodage des fichiers programmés.
Bonsoir Maximus !  :ik:
Bah oui, en plus il est gratos !  :jw:
IP archivée
Jean Claude :gt:

alex

  • Administrateur
  • Dictionnaire ambulant
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 15.284
  • Proprio officiel chez oim !

Jacky, ça m'étonne que ce soit un problème d'encodage.
Je travaille toujours en UTF-8 au format UNIX (pour les sauts de lignes), et Unbound ne m'a jamais emmerdé.
A vrai dire, tant qu'il n'y a pas d'accents ou de caractères spéciaux, l'encodage a peu d'importance.
Windows commence même à s'habituer à l'UTF-8, pas en ligne de commandes où UTF-8 affiche un grand n'importe quoi, mais Microsoft a fait le minimum syndical pour essayer de prendre en charge UTF-8.

Par contre, sous Windows, un problème peut se montrer si on a les paramètres par défaut de l'explorateur, c'est le paramètre "masquer les extensions des fichiers dont le type est connu".
En travaillant avec cette saleté de bloc note, sur service.conf par exemple, il va comprendre qu'on est sur un fichier texte et renommer le fichier en service.conf.txt et tu ne verras pas le .txt qui sera caché par l'explorateur !

Et tous les fichiers texte que tu enregistreras avec ce bloc note se verront affubler de ce .txt invisible...
La première chose à faire est donc d'afficher l'extension des fichiers, même si leur type est connu, parce que c'est comme ça qu'on se retrouve avec des erreurs de "Fichier inexistant" et que c'est surtout la meilleure façon de se faire refiler une vérole.

Il faut d'abord se rendre dans l'explorateur (n'importe où), en ouvrant un dossier (n'importe lequel).
Ensuite, touche ALT pour montrer les menus (vas comprendre pourquoi c'est caché), ensuite Outils puis Options des dossiers et sur l'onglet affichage, tu décoches masquer les extensions des fichiers dont le type est connu.
Ensuite, tu installes un éditeur un peu mieux que ce bloc note qui est Notepad++. ;)
Fais gaffe à la version 64 bits, je la déconseille, il n'existe aucun plugin pour cette version. Seule la 32 bits propose des plugins.


Ceci dit, Windows est tellement con que ce problème d'encodage existe peut-être bien chez toi ! Chez Microsoft, faut pas toujours chercher à comprendre...
Merci pour ton feed back ! :)
IP archivée

Jacky

  • Orateur balbutiant
  • Hors ligne Hors ligne
  • Messages: 13

Alex je te confirme toujours utiliser l'explorateur en visibilité totale, y compris fichiers cachés ....
Pour vérifier j'ai volontairement sauvé en utf8 et là ça bloque , remis en ANSI tout fonctionne...!! 
Cela 2 machines sur trois, pour info, ...
 O:-)
IP archivée

relai56

  • Observateur
  • Orateur balbutiant
  • Hors ligne Hors ligne
  • Messages: 7

bonjour,
 je reviens à la charge.
Suite à un changement d'antivirus/pare-feu, je n'avais plus accès au net. Désinstallation/réinstallation du driver, remplacement des 2 fichiers préconisés dans le dossier Unbound, redémarrage du service.
Le champs "Utiliser l'adresse...." était vierge !
Je rentre à nouveau 127.0.0.1
Je récupère la connexion mais : cmd > vidage cache > nslookup google.fr =

Code
Serveur : Localhost
Adress : 127.0.0.1

DNS  request timed out.
  timed out was 2 seconds
  ""          ""          ""       ""
*** le délai de la requête sur localhost est dépassé.


Parfois, pour changer :  :-[
 
Code
*** localhost ne parvient pas à trouver (soit google, soit t411) : Server failed

 Une petite idée ??

 merci d'avance  ;)

[edit] tant que j'étais sur ce forum, j'ai pu changer de page. Je quitte le forum puis, voulant continuer le surf : plus de connexion. J'efface le fameux 127.0.0.1 et ça repart.  (??!!)
IP archivée

alex

  • Administrateur
  • Dictionnaire ambulant
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 15.284
  • Proprio officiel chez oim !

2 secondes, ça fait léger. Un DNS peut parfois prendre plus de temps.
Ma foi, c'est Windows...

Tu as bien le fichier named.cache dans le dossier de Unbound ? Tu as vérifié son contenu ?
Si ton DNS ne trouve rien, l'absence des DNS racine peut être le responsable.

Essaye la requête suivante :
Code
nslookup a.root-servers.net


Alex je te confirme toujours utiliser l'explorateur en visibilité totale, y compris fichiers cachés ....
Pour vérifier j'ai volontairement sauvé en utf8 et là ça bloque , remis en ANSI tout fonctionne...!! 
Cela 2 machines sur trois, pour info, ...
 O:-)

Alors ça, ben c'est pas banal. Je savais que Windows adore son ANSI, mais à ce point. :-\
IP archivée

relai56

  • Observateur
  • Orateur balbutiant
  • Hors ligne Hors ligne
  • Messages: 7


Essaye la requête suivante :
Code
nslookup a.root-servers.net

 pfff !! mauvaise semaine. Me revoilà après des pb de double-boot W7/Linux . J'ai voulu réparer avec Boot Repair :  W7 ne voulait plus se lancer,....bref, les choses sont en place désormais.
 
 ¨Pour ce qui est de la connexion, ça fonctionne ,  maintenant. Va savoir pourquoi....

 Oui, named.cache est bien en place. DNS 127.0.0.1. (la Livebox n'a rien à voir ?)

Je te mets le résultat :


Code
Serveur :    Unknow
Adress :   fe80::7a81 :2ff:fe2e:89e6

 Réponse ne faisant pas autorité :
Nom :  a.root-servers.net
Adresses: 2001 :503:ba3e::2:30
      198.41.0.4
IP archivée

alex

  • Administrateur
  • Dictionnaire ambulant
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 15.284
  • Proprio officiel chez oim !

Oups ! Désolé, je te vois seulement. :je:


Le résultat est correct, mais tu as un problème quand même.

Vérifie la configuration de ta carte réseau. C'est là que se trouve le problème.
Ta carte n'utilise pas Unbound.
Au pire, décoche IPv6. Ce n'est pas très élégant, mais ce n'est pas dramatique non plus.

C'est pas la première fois que je vois ce type de souci avec une LiveBox... :??
IP archivée

relai56

  • Observateur
  • Orateur balbutiant
  • Hors ligne Hors ligne
  • Messages: 7

Oups ! Désolé, je te vois seulement. :je:

salut,

 t'inquiète, je ne suis pas pressé.

 IPv6 décoché, je réitère la requête :

Code
 Serveur :  localhost
Address : 127.0.0.1

Réponse ne faisant pas autorité :
Nom :  a.root-servers.net
Adresses: 2001 :503:ba3e::2:30
      198.41.0.4

 Bon,...ya une différence mais c'est toi qui pourra m'éclairer.
Pour moi, c'est du chinois.....mais quand même, j'y vois un progrès car la première partie (localhost/Address) est revenue.
IP archivée

alex

  • Administrateur
  • Dictionnaire ambulant
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 15.284
  • Proprio officiel chez oim !

Salut,

Là c'est tout bon. Ton DNS fonctionne parfaitement et il est utilisé par ta carte réseau. :)

Fais le test suivant, le résultat devrait être positif (c'est un site bloqué par la justice française, mais tu devrais avoir la réponse, vu que tu as ton DNS personnel) :
Code
nslookup allomovies.com

IP archivée
Pages: 1 ... 6 7 8 [9]   En haut
 

+ Réponse Rapide

Page générée en 0.088 secondes avec 18 requêtes.