Attention ! Ne cliquez pas sur ce lien, c'est un piège à enfoirés du net !

Chez oim, forum libreChez oim, forum libre

 

Auteur Sujet: Discussions autour de Wamp avec un de ses créateurs, Otomatic  (Lu 74019 fois)

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.220
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #794 le: jeudi 16 septembre 2021, 16:05 »
le: jeudi 16 septembre 2021, 16:05

Bonjour,

- Apache 2.4.49 32bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x86_addon_apache2.4.49.exe
- Apache 2.4.49 64bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x64_addon_apache2.4.49.exe

Important: Avant d'installer Apache 2.4.49, la mise à jour Wampserver 3.2.5 ou plus est nécessaire. Il est également indispensable d'avoir préalablement installé les Visual C++ Redistribuable Packages VC 2015-2019 (VS16) 14.29.30133 ou plus.

Changelog
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

JCFM

  • Observateur
  • Pipelette invétérée
  • *******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 2.990
  • Choléra officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #795 le: jeudi 16 septembre 2021, 20:20 »
le: jeudi 16 septembre 2021, 20:20

 :ik:
 :jw:
Merci
Signaler au modérateur   IP archivée
Jean Claude :gt: Le "Choléra" officiel de chez Oim ! Alcoolique invétéré !

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.220
  • Vieux geek assagi
      • Aviatechno
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 21.162
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #797 le: mercredi 22 septembre 2021, 19:25 »
le: mercredi 22 septembre 2021, 19:25

Qu'est-ce que je peux faire marcher aujourd'hui sous Win7 ? :-\
Version de Wamp, PHP, MariaDb, Apache.

Si vous avez besoin de testeurs Win7, dans vos contrées, pour revenir dans le droit chemin, n'hésite pas à demander. ;)
Win7 est encore très présent !

C'est le XP de l'époque, beaucoup de monde s'y accroche ! :jr:
Je te trouverai des chiffres.
Signaler au modérateur   IP archivée

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.220
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #798 le: jeudi 23 septembre 2021, 07:59 »
le: jeudi 23 septembre 2021, 07:59

Bonjour,

A priori, il n'y a que MariaDB après 10.4.12 qui ne fonctionne pas sous Windows 7.
« Le point d'entrée de la procédure GetSystemTimePreciseAsFileTime est introuvable dans kernel32.dll »
Citation
Since Windows 7 is unsupported, MariaDB is no longer built or tested for it, and you'd have to try compile MariaDB yourself, and deal with any issues that arise. Alternatively dual-boot on Linux or install a virtual host.

La dernière version Wampserver installable sous W7 est la version 3.2.0 :
- 3.2.0 32bit
https://wampserver.aviatechno.net/files/install/wampserver3.2.0_x86.exe
- 3.2.0 64bit
https://wampserver.aviatechno.net/files/install/wampserver3.2.0_x64.exe

Toutes les mises à jour Wampserver au moins jusqu'à 3.2.6, tous les addons Apache, PHP, MySQL, les applications comme PhpMyAdmin, Adminer, etc. sont installables sous W7 et semblent fonctionner sans problème.
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.220
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #799 le: jeudi 23 septembre 2021, 17:33 »
le: jeudi 23 septembre 2021, 17:33

Bonjour,

La prochaine version Wampserver “full install” 3.2.6 pourra être installée sous Windows 7 SP1, mais seulement avec MariaDB 10.4.12, dernière version supportant W7.
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 21.162
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #800 le: jeudi 23 septembre 2021, 19:53 »
le: jeudi 23 septembre 2021, 19:53

A oui quand même.
J'imaginais que Wamp n'était plus préoccupé par Win7 vu les soucis d'install que j'ai déjà rencontré dans le passé (installez Wamp X, cet addon n'est pas compatible, etc.).

Et ben c'est cool, je vais pouvoir modifier mon installation ! :)
Je me demande même si je ne vais pas tout virer et réinstaller après. Mon Wamp devient un bordel sans nom avec tous les bricolages que j'ai fait (je n'utilise jamais wampmanager qui est toujours à l'arrêt chez moi).
Il faut absolument que je teste PHP 7.4 avec chez oim, avant d'être le nez sur le mur...

Mon gros souci avec ma version de Wamp, c'est le php.ini qui est le même pour toutes les versions de PHP installées.
Je ne comprends pas que ce fichier se trouve dans le dossier de Apache !.. Chaque version de PHP devrait avoir son php.ini, de la même façon que Apache à son httpd.conf.
Ce problème est réglé avec les versions de Wamp supérieures à 3.2.3 ?




En tout cas, je vais revoir mon installation locale, ça fera du bien. ;)
Signaler au modérateur   IP archivée

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.220
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #801 le: vendredi 24 septembre 2021, 09:45 »
le: vendredi 24 septembre 2021, 09:45

Mon gros souci avec ma version de Wamp, c'est le php.ini qui est le même pour toutes les versions de PHP installées.
Mais non, mais non  :jc:
Il faut aller un peu plus loin que le bout de son nez !

Un dir sur ce « fichier » php.ini donne :
Code
E:\wamp64\bin\apache\apache2.4.49\bin>dir php.ini
 Le volume dans le lecteur E s’appelle SATA_1_E
 Le numéro de série du volume est F491-4AA3

 Répertoire de E:\wamp64\bin\apache\apache2.4.49\bin

24/09/2021  09:20    <SYMLINK>      php.ini [E:/wamp64/bin/php/php8.0.11/phpForApache.ini]
               1 fichier(s)                0 octets
               0 Rép(s)  85 142 233 088 octets libres

E:\wamp64\bin\apache\apache2.4.49\bin>
Ce n'est pas un fichier à proprement parler, c'est un lien symbolique sur le fichier phpForApache.ini de la version php utilisée.
Si je change de version php, par exemple 7.4.24, ce sera toujours le “fichier” php.ini dans le dossier bin d'Apache, mais on aura :
Code
E:\wamp64\bin\apache\apache2.4.49\bin>dir php.ini
 Le volume dans le lecteur E s’appelle SATA_1_E
 Le numéro de série du volume est F491-4AA3

 Répertoire de E:\wamp64\bin\apache\apache2.4.49\bin

24/09/2021  09:41    <SYMLINK>      php.ini [E:/wamp64/bin/php/php7.4.24/phpForApache.ini]
               1 fichier(s)                0 octets
               0 Rép(s)  85 142 228 992 octets libres

E:\wamp64\bin\apache\apache2.4.49\bin>
Ce lien symbolique pointe maintenant sur le phpForApache.ini de la version 7.4.24 de php.

CQFD  :jr:
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 21.162
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #802 le: vendredi 24 septembre 2021, 12:36 »
le: vendredi 24 septembre 2021, 12:36

A ben voilà, ça c'est bien le coup du lien symbolique. :jw:
Mais c'est à partir de quelle version ?

Avec ma version (3.2.3), pas de lien symbolique en vue...

Code
E:\wamp\bin\apache\apache2.4.43\bin>dir php.ini
 Le volume dans le lecteur E s'appelle DATA
 Le numéro de série du volume est B8F4-EE10

 Répertoire de E:\wamp\bin\apache\apache2.4.43\bin

23/09/2021  19:12            73 857 php.ini
               1 fichier(s)           73 857 octets
               0 Rép(s)  233 080 373 248 octets libres

E:\wamp\bin\apache\apache2.4.43\bin
Signaler au modérateur   IP archivée

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.220
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #803 le: vendredi 24 septembre 2021, 13:44 »
le: vendredi 24 septembre 2021, 13:44

Bonjour,

Les liens symboliques, ça date de Wampserver 3.0.0… mais, pour que ça fonctionne correctement, il faut changer de version PHP via les menus de Wampmanager et pas à la mimine. (Clic-Gauche -> PHP -> Version -> choix version)
Mets à jour en 3.2.5, vérifie dans wampmanager.conf section [options] -> CreateSymlink = "symlink"
Puis :
Clic-Droit -> Rafraîchir
Clic-Droit -> Outils -> Vérifier les liens symboliques

Attention : Cette option CreateSymlink est obsolète et disparaîtra avec la version 3.2.6 et seule subsistera les liens symboliques. Il en sera plus possible d'avoir l'option "copy".
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 21.162
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #804 le: vendredi 24 septembre 2021, 19:18 »
le: vendredi 24 septembre 2021, 19:18

Hallelujah ! :ic:

J'ai essayé avec ma version 3.2.3 et j'ai enfin des liens symboliques vers chaque version de PHP selon ce que j'ai choisi.
C'est ma config qui était sur CreateSymlink = "copy", enfin je crois que c'est ça.

Perso, j'aurais créé un lien vers php.ini, mais pourquoi pas phpForApache.ini ?
Ca vas me faire des copier/coller supplémentaires.

Et voilà le Saint Graal : :)
Un Wamp qui fonctionne enfin comme je le veux. Bravo les mecs ! :jw:

Code
E:\wamp\bin\apache\apache2.4.43\bin>dir php.ini
 Le volume dans le lecteur E s'appelle DATA
 Le numéro de série du volume est B8F4-EE10

 Répertoire de E:\wamp\bin\apache\apache2.4.43\bin

24/09/2021  14:40    <SYMLINK>      php.ini [E:/wamp/bin/php/php7.1.33/phpForApache.ini]
               1 fichier(s)                0 octets
               0 Rép(s)  233 111 576 576 octets libres

E:\wamp\bin\apache\apache2.4.43\bin>

Dernière question et je te laisse passer ton week-end en toute tranquillité. :is:
Où est-ce que je peux trouver les plugins (ou addons) (PHP, Apache, etc...) ? Chez toi ou sur wampserver.com ?

EDIT

Encore une question.
C'est possible d'avoir des liens vers les dossiers de la page d'accueil Wamp plutôt que de créer des VHOST pour chaque ?
J'ai exactement 128 dossiers, alors créer des VHOST, c'est pas franchement excitant...
Signaler au modérateur   IP archivée

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.220
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #805 le: vendredi 24 septembre 2021, 19:45 »
le: vendredi 24 septembre 2021, 19:45

Perso, j'aurais créé un lien vers php.ini, mais pourquoi pas phpForApache.ini ?
php.ini c'est pour php en CLI. phpForApache.ini_ c'est pour le WEB.
C'est pour éviter que si un utilisateur fait n'importe quoi, genre valider des extensions sans savoir, et que ça plante PHP WEB, et bien la version CLI n'est pas plantée et les scripts Wampmanager fonctionnent toujours.
Un Wamp qui fonctionne enfin comme je le veux. Bravo les mecs ! :jw:
Euh !… Y'en a plus qu'un !
Où est-ce que je peux trouver les plugins (ou addons) (PHP, Apache, etc...) ?
Chez moi : https://wampserver.aviatechno.net
C'est possible d'avoir des liens vers les dossiers de la page d'accueil Wamp plutôt que de créer des VHOST pour chaque ?
Click-Droit -> Paramètres Wamp -> Afficher dossiers www dans menu……  pour cocher l'option
et dans le menu Clic-Gauche, il y aura un item -> Répertoire www
À moins que ce soit autre chose que tu veuilles !
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 21.162
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #806 le: vendredi 24 septembre 2021, 20:04 »
le: vendredi 24 septembre 2021, 20:04

Tu te retrouves tout seul à gérer Wamp ?! :o
Ben merde alors, ça fait du boulot...

je n'ai pas "Afficher dossiers www"...




Ce que je veux est simple : Maintenant Wamp affiche les dossiers de WWW mais il faut créer des VHOST pour y avoir accès.
J'aimerais avoir des liens sur ces dossiers comme c'était le cas avant.
Signaler au modérateur   IP archivée

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.220
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #807 le: vendredi 24 septembre 2021, 20:34 »
le: vendredi 24 septembre 2021, 20:34

Mets à jour en 3.2.5
Quand je dis "tout seul", c'est pas exact, y'a Maximus23 pour Aestan Tray Menu, autrement dit Wampmanager.exe, et c'est pas une mince affaire.
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 21.162
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #808 le: vendredi 24 septembre 2021, 20:40 »
le: vendredi 24 septembre 2021, 20:40

Ok, je fais ça et je te dis.

Ca vaut le coup de mettre à jour Aestan, vu que je l'utilise très peu ?
Signaler au modérateur   IP archivée

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 21.162
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #809 le: vendredi 24 septembre 2021, 20:44 »
le: vendredi 24 septembre 2021, 20:44

Il n'y a que la version 3.2.3 de proposée... (celle que j'ai)
J'ai essayé de bricoler l'URL en changeant 3.2.3 en 3.2.5 mais je tombe sur un 404.

EDIT

Ah si, j'ai trouvé plus bas !
Signaler au modérateur   IP archivée
 

+ Réponse Rapide

Page générée en 0.061 secondes avec 21 requêtes.