Attention ! Ne cliquez pas sur ce lien, c'est un piège à enfoirés du net !

Chez oim, forum libreChez oim, forum libre

 
Pages: 1 ... 63 64 65 [66] 67 68 69 ... 72   En bas

Auteur Sujet: Discussions autour de Wamp avec un de ses créateurs, Otomatic  (Lu 169860 fois)

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 23.049
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #974 le: jeudi 23 février 2023, 20:03 »
le: jeudi 23 février 2023, 20:03

Le vcredist140 v14.34.31931 est passé à la version 14.34.31938 ;)
Signaler au modérateur   IP archivée

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.643
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #975 le: mardi 07 mars 2023, 16:09 »
le: mardi 07 mars 2023, 16:09

Bonjour,

- Apache 2.4.56 32bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x86_addon_apache2.4.56.exe

- Apache 2.4.56 64bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x64_addon_apache2.4.56.exe

Important: Avant d'installer Apache 2.4.56, la mise à jour Wampserver 3.3.1 ou plus est nécessaire. Il est également indispensable d'avoir préalablement installé les Visual C++ Redistribuable Packages VC 2015-2022 (VS17) 14.34.31938 ou plus.
Intègre le module Apache fcgi_module qui permet de changer la version PHP de chaque VirtualHost afin d'obtenir des VirtualHost avec différentes versions de PHP

- Open SSL 1.1.1t & 3.0.8

Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.643
  • Vieux geek assagi
      • Aviatechno
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.643
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #977 le: mercredi 22 mars 2023, 10:30 »
le: mercredi 22 mars 2023, 10:30

Bonjour,

- Mise à jour xDebug version 3.2.1 pour les versions PHP 8.0.x à 8.2.x 64bit seulement installées.
Peut être réinstallé en cas d'ajout de version PHP.
Version de correction de bogues qui corrige les problèmes liés à la configuration du mode de Xdebug dans les environnements threadés, où Xdebug ignorait la valeur et activait toujours tout. Cette version corrige également un crash qui se produit lorsque vous essayez de définir un paramètre php.ini standard qui a été déprécié.

https://wampserver.aviatechno.net/files/updates/wampserver3_update_xdebug_3.2.1.exe
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.643
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #978 le: jeudi 06 avril 2023, 12:25 »
le: jeudi 06 avril 2023, 12:25

Bonjour,

- Apache 2.4.57 32bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x86_addon_apache2.4.57.exe

- Apache 2.4.57 64bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x64_addon_apache2.4.57.exe

Important: Avant d'installer Apache 2.4.57, la mise à jour Wampserver 3.3.1 ou plus est nécessaire. Il est également indispensable d'avoir préalablement installé les Visual C++ Redistribuable Packages VC 2015-2022 (VS17) 14.34.31938 ou plus.
Intègre le module Apache fcgi_module qui permet de changer la version PHP de chaque VirtualHost afin d'obtenir des VirtualHost avec différentes versions de PHP

- Open SSL 1.1.1t & 3.0.8
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 23.049
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #979 le: jeudi 06 avril 2023, 19:33 »
le: jeudi 06 avril 2023, 19:33

Cool ! :)

Juste un truc, comme ça, en vitesse.
Ca te dirait d'inclure les modules mod_security et mod_evasive par défaut dans Apache ?
Je m'y intéresse depuis hier et ces modules sont vraiment bien en matière de sécurité.

Le premier détecte les tentatives de bruteforce, entre autre, quand le second détecte et condamne les attaques DDoS.
Pas mal, non ?
Signaler au modérateur   IP archivée

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.643
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #980 le: mercredi 12 avril 2023, 15:05 »
le: mercredi 12 avril 2023, 15:05

Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.643
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #981 le: lundi 17 avril 2023, 11:42 »
le: lundi 17 avril 2023, 11:42

Bonjour,

- Apache 2.4.57.1 32bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x86_addon_apache2.4.57.1.exe

- Apache 2.4.57.1 64bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x64_addon_apache2.4.57.1.exe

Important: Avant d'installer Apache 2.4.57.1, la mise à jour Wampserver 3.3.1 ou plus est nécessaire. Il est également indispensable d'avoir préalablement installé les Visual C++ Redistribuable Packages VC 2015-2022 (VS17) 14.34.31938 ou plus.
Intègre le module Apache fcgi_module qui permet de changer la version PHP de chaque VirtualHost afin d'obtenir des VirtualHost avec différentes versions de PHP
- Open SSL 1.1.1t & 3.0.8

Version 64bit : mod evasive 2.2.0 - mod security 2.9.7
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 23.049
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #982 le: lundi 17 avril 2023, 19:16 »
le: lundi 17 avril 2023, 19:16

Version 64bit : mod evasive 2.2.0 - mod security 2.9.7

Voilà, parfait ! :if:
Signaler au modérateur   IP archivée

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.643
  • Vieux geek assagi
      • Aviatechno
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 23.049
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #984 le: lundi 24 avril 2023, 21:49 »
le: lundi 24 avril 2023, 21:49

Il semblerait qu'il y a un souci avec Wamp 3 et l'installation des addons Apache.
C'est une installation neuve.

Lorsque je veux installer un ancien PHP, pas de souci, ça se passe correctement.
Mais quand je passe à Apache, il me dit que le chemin choisi n'est pas correct. Hors, il ne me propose aucun chemin ! (comme avec PHP d'ailleurs).
L'installeur me dit qu'il a toutes les infos pour y aller, et pouf ! Voilà ce que je prends...




Si je clique sur "Précédent", je retombe sur la fenêtre qui dit que tout va bien, il a toutes les infos.
J'ai essayé un autre Apache, mais rien n'y fait.


Merci pour tes lumières.
Signaler au modérateur   IP archivée

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 23.049
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #985 le: lundi 24 avril 2023, 21:56 »
le: lundi 24 avril 2023, 21:56

Ah ben je viens d'y arriver.
Il faut que le Wamp Manager soit lancé pour que ça passe.
Ma foi !..
Signaler au modérateur   IP archivée

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 23.049
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #986 le: mardi 25 avril 2023, 14:18 »
le: mardi 25 avril 2023, 14:18

Bon ben mon Apache ne marche toujours pas.
Pas de problème du côté de MySQL et MariaDB.

A chaque fois je prends des erreurs incompréhensibles.
Au début je me suis dit que c'était une histoires de droits. Alors j'ai désinstallé et réinstallé le service en mode admin. Mais non... :gk:

P'tain ! C'est la seule chose qui marche pas sur mon Win10.
Je précise que l'installation est neuve, j'ai tout désinstallé et réinstallé la version 3.2.6 (j'ai changé, la version 3.3 me sortait les mêmes erreurs).

Voilà les erreurs relevées dans l'observateur d'événements Windows (je n'ai absolument rien dans les logs et httpd -t me dit Syntax OK) :

Code
The Apache service named reported the following error:
  >>> (OS 10013)Une tentative d’accès à un socket de manière interdite par ses autorisations d’accès a été tentée.  :
  AH00072: make_sock: could not bind to address [::]:80

The Apache service named reported the following error:
  >>> (OS 10013)Une tentative d’accès à un socket de manière interdite par ses autorisations d’accès a été tentée.  :
  AH00072: make_sock: could not bind to address 0.0.0.0:80

The Apache service named reported the following error:
  >>> AH00451: no listening sockets available, shutting down

The Apache service named reported the following error:
  >>> AH00015: Unable to open logs


Au début, je me disais que le bidule ne travaillait pas avec les droits Admin.
Mais en recommençant avec les bons droits, ça ne va toujours pas... :(

Si Oto ou Alain avaient une idée, je ne vous cache pas que ça me réjouirait !
Je ne peux pas me passer de Apache, c'est pas possible. C'est en local que je travaille sur ce site avant d'exporter les modifs.
Merci d'avance ! :blank:


Config Wamp :
Wamp 3.2.6 x64
Apache 2.4.43 & 2.4.51 (l'actuelle est 2.4.43 mais ça fait pareil avec la 2.4.51)
PHP 5.6.40, 7.1.33, 7.2.34, 7.3.33, 7.4.26, 8.0.13 & 8.1.0 (l'actuelle est 7.1.33 mais ça fait pareil avec toutes les autres)


Je précise que l'installation est neuve, je n'ai encore rien touché !
Bien entendu, tous les paquetages VC++ sont installés et vérifiés avec le dernier exécutable à disposition.





A ce soir j'espère ! :ij:
 :ig:
Signaler au modérateur   IP archivée

JCFM83

  • Invité
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #987 le: mercredi 26 avril 2023, 13:15 »
le: mercredi 26 avril 2023, 13:15

La dernière version de Wamp est « Wampserver 3.3.0 64 bit» !
Mise à jour depuis avec « Wampserver update 3.3.1 » !
A installé en tant qu’administrateur.
Ayant rencontré tout comme toi des problèmes, j’ai réinstallé ce qui suit.
Apache 2.4.51 - PHP 7.4.26 -  Maria 10.6.5
Bien entendu, j’utilise toujours le dernier outil d’Oto pour contrôler et mettre à jour les paquetages VC x86 & x64 ils sont à notre disposition sur son site.
Pour conclure, j'en ai essayé plusieurs, et ils ont des métros en retard, Wamp et de loin le meilleur, et avec les suivis et les mises à jour gratuites que mets à notre disposition « Oto », j'apprécie cet esprit de partage.

Désinstalle complètement ta version, effectue une nouvelle installation, ce qui est très rapide, et tu constateras que tout fonctionne.
De mon côté, je n'ai aucun problème avec les versions apaches et Maria, ce qui n'est pas le cas avec les versions de PHP 8. Xxx, avec certaines des extensions que j’utilise pour mes sites, j’effectue les corrections petit à petit quand j’ai le temps.
En plus, surprise, quand je transfère chez mon hébergeur, il n'y a aucun problème ! Pourtant, PHP 8.0.28


Pourquoi se prendre la tête et je ne suis pas assez calé pour comprendre.


Cordialement.
Jean-Claude





Messages du même membre fusionnés car compris dans le délai d'édition
(Vous avez 30 minutes pour éditer).

Utilisation mémoire
actu elle : 66 M B Mémoire maxi mum : 256M
Version PHP: 8.0.28 -
Version MySQL : 10.6.12-MariaDB
Taille maximale des Paquets de la base de
données : 256 MB Mode SQL actu el :
Version Cu rt :  7.84.0/ SSL:OpenSSL/1.1.1p / libz: 1.2.7 Version OpenSSL :  OpenSSL 1.1.1p 2 1 Jun 2022
MCrypt: Non ZipArchive::add File: Non
Exécutab le zip trouvé:   Oui:/usr/bin/zip
ModulH Apache: auth_basic, expires, headers, mime, rewnte
Signaler au modérateur   IP archivée

Otomatic

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.643
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #988 le: mercredi 26 avril 2023, 14:54 »
le: mercredi 26 avril 2023, 14:54

Bonjour,

Normalement, les demandes de support doivent être effectuées dans les forums afférents Wampserver :
Forum francophone
Forum anglophone
parce que gérer des réponses dans plusieurs endroits est extrêmement chronophage et fatiguant.

Néanmoins et parce qu'il s'agit d'une nouvelle installation sur un Windows 10 fraîchement installé :

- As-tu installé et vérifié tous les VC++ AVANT d'installer Wampserver ?

Si problème après installation, la communication des messages d'erreur complets et exacts est extrêmement importante.

Si le service wampapache64 ne démarre pas il faut donner le résultat de :
Clic-Droit -> Outils -> Vérifier l'état des services
C'est indiqué dans le popup affiché avec le curseur sur l'icône Wampserver. Quand tout va bien, il est indiqué Tous les services sont lancés
Signaler au modérateur   IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Moulin à paroles
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 23.049
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #989 le: mercredi 26 avril 2023, 19:28 »
le: mercredi 26 avril 2023, 19:28

Désolé, je suis passé hier sur tes forums, mais qu'est-ce que c'est austère !
Pas de mise en forme (BBCODE), pas d'images. Et dans les fenêtres on est un peu à l'étroit.
Ca sent le vieux forum qui n'a pas été passé en Responsive. ;)

Sinon oui, tous les paquetages sont installés, c'est dit dans mon post et avec une image en prime.
Les messages d'erreur de l'observateur d'événement sont là aussi.

Voici le message obtenu par "Etat des services" : (Apache non quand SQL démarre sans souci)
Les codes d'erreur sont les mêmes que pour Windows.

Code
State of services:

 The service 'wampapache64' is NOT started
 EXIT error code:1066
 Help message for error code 1066 is:Le service a renvoyé un code d'erreur qui lui est spécifique.
>>> AH00015: Unable to open logs     .
>>> AH00451: no listening sockets available, shutting down     .

 The service 'wampmysqld64' is started
 Service Session : LocalSystem

 The service 'wampmariadb64' is started
 Service Session : LocalSystem

        all services BINARY_PATH_NAME are OK

Pour ce qui est des logs, il n'y a pas d'erreur de config.
Regarde les messages sortis de l'observateur d'événements dans mon premier post, ils sont bien plus précis.


Je pense comme JCFM, Wamp n'a pas été installé avec les permissions admin.
Je vais tenter de réinstaller tout ça en forçant les droits Admin.

Tu sais que tu peux forcer les droits admins dans un installer Inno Setup ? Ce serait quand même plus pratique.

Code
[setup]
PrivilegesRequired=admin
Signaler au modérateur   IP archivée
Pages: 1 ... 63 64 65 [66] 67 68 69 ... 72   En haut
 

Page générée en 0.099 secondes avec 19 requêtes.