Chez oim, forum libreChez oim, forum libre

 


Pages: 1 ... 10 11 12 [13] 14 15 16 ... 24   En bas

Auteur Sujet: Discussions autour de Wamp avec un de ses créateurs, Otomatic  (Lu 2939 fois)

JCFM

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.916
  • Choléra officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #179 le: dimanche 13 janvier 2019, 20:29 »
le: dimanche 13 janvier 2019, 20:29

Bonjour,

J'ai profité de ce dimanche ensoleillé (6 minutes 32 secondes) pour bosser m'amuser.

--- Installeurs complets Wampserver 3.1.7 32 & 64 bit comprenant :
- Apache 2.4.37 - PHP 5.6.40/7.0.33/7.1.26/7.2.14/7.3.1 - MySQL 5.7.24 - MariaDB 10.3.12
- PhpMyAdmin 4.8.4 - Adminer 4.7.0 - PhpSysInfo 3.2.10

--- Mise à jour Wampserver 3.1.7

Voir sur http://wampserver.aviatechno.net/?lang=fr

Maintenant ->  :ko:

Bonsoir et merci !
Maj faite et installé PHP  3.1.7
Il me semble que c'est + rapide ?
Merci
Cordialement
Jean Claude
IP archivée
Jean Claude :gt: Le "Choléra" officiel de chez Oim ! Alcoolique invétéré !

alex

  • Administrateur
  • Dictionnaire ambulant
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 18.076
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #180 le: dimanche 13 janvier 2019, 22:51 »
le: dimanche 13 janvier 2019, 22:51

Toujours pas de SSL en vue ?
Ca semblait t'intéresser pourtant. :-\


JC, c'est pas PHP 3.1.7 mais Wamp 3.1.7
Et c'est pas plus rapide, c'est juste l'effet placebo. ;)
IP archivée

Otomatic

  • Observateur
  • Grand orateur
  • ***
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 222
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #181 le: lundi 14 janvier 2019, 09:27 »
le: lundi 14 janvier 2019, 09:27

Toujours pas de SSL en vue ?
Il y a “un certain temps” © Fernand Raynaud, j'ai, ici même, donné un topo qui fonctionne pour installer SSL https sur Wampserver. Je ne ferai — pour le moment — rien en automatique ou en installeur.

Et c'est vrai que côté rapidité, c'est l'effet nouveauté  :id:
IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

JCFM

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.916
  • Choléra officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #182 le: lundi 14 janvier 2019, 11:10 »
le: lundi 14 janvier 2019, 11:10

Toujours pas de SSL en vue ?
Ca semblait t'intéresser pourtant. :-\


JC, c'est pas PHP 3.1.7 mais Wamp 3.1.7
Et c'est pas plus rapide, c'est juste l'effet placebo. ;)
Salut la Foule !  :ik:
Lèche journalière, Majesté !
Oui, je m'en suis rendu compte après l'envoi et pas envie de modifier, je me doutais que tu corrigerais de toi-même !
Pour l'effet placebo, tu repasseras !
Dominique, plus sympa, résume en "l'effet nouveauté" !
Bah, non, Messieurs !
De PHP 7.2.10 à la 7.3.1 c'est + rapide avec .............Wordpress, surtout constaté avec mon site le  + lourd,  "rencontre" !

Pour le SSL,  bien entendu, j'attends, lol, trop compliqué pour moi, les modifs ! :iq:
IP archivée
Jean Claude :gt: Le "Choléra" officiel de chez Oim ! Alcoolique invétéré !

maximus23

  • Observateur
  • Pipelette invétérée
  • *******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 2.201
  • Grand chevalier du mot de passe
      • ®Smf® Solutions
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #183 le: lundi 14 janvier 2019, 12:05 »
le: lundi 14 janvier 2019, 12:05

Bonjour,

Testé et approuvé pour le patch 3.1.7.

Pour Alex pour activer le http/2 rien de plus simple ici je l'ai mis depuis longtemps.

Activer l'extension : LoadModule http2_module modules/mod_http2.so

Le faire dans le fichier conf d'apache directement car si je le fais directement via le gestionnaire d'extension au démarrage suivant il me le retire pourquoi mystère de la nature….

Mettre dans Apache après les extensions la directive : Protocols h2 h2c http/1.1

Redémarrer et c'est tout comme on est déjà avec un SSL / TLS / Cypher en haute sécurité pas de soucis.

Pour ceux pour qui ce ne serait pas le cas cela fera une rétrogradation sur le 1.1 car il faut un cypher correct.





:)

Si on a plusieurs sites on peut le mettre uniquement sur un site ou plusieurs en mettant le Protocol dans le Vhost en 443 en dessous du nom de domaine.

Donc c'est ultra simple à mettre en place.

Pour linux il faut compiler l'extension la mettre en activité et le tout est joué.

:)
IP archivée
Amitiés et à bientôt...
Have a nice day...

Otomatic

  • Observateur
  • Grand orateur
  • ***
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 222
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #184 le: lundi 14 janvier 2019, 18:01 »
le: lundi 14 janvier 2019, 18:01

Le faire dans le fichier conf d'apache directement car si je le fais directement via le gestionnaire d'extension au démarrage suivant il me le retire pourquoi mystère de la nature….
:ge:  :ge:
Clic-Gauche -> Apache -> Modules Apache -> http2_module   pour le cocher
Le module reste décommenté dans httpd.conf, même aux démarrages suivants.

Je n'ai ce problème sur aucun de mes quatre Wampserver : Installations complètes Wampserver 3.1.7 32 et 64 bit sous Windows 7 Pro 64 bit et Windows 10 Pro 64 bit.
IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

alex

  • Administrateur
  • Dictionnaire ambulant
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 18.076
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #185 le: lundi 14 janvier 2019, 19:29 »
le: lundi 14 janvier 2019, 19:29

Perso, ça fait un moment que j'ai HTTP/2. ;)


Je ne ferai — pour le moment — rien en automatique ou en installeur.

C'est dommage, il ne manque plus que ça à Wamp pour être complet.
Surtout avec tous ceux qui ne maitrisent pas du tout le sujet. :iz:
IP archivée

maximus23

  • Observateur
  • Pipelette invétérée
  • *******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 2.201
  • Grand chevalier du mot de passe
      • ®Smf® Solutions
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #186 le: lundi 14 janvier 2019, 19:48 »
le: lundi 14 janvier 2019, 19:48

Je n'ai ce problème sur aucun de mes quatre Wampserver : Installations complètes Wampserver 3.1.7 32 et 64 bit sous Windows 7 Pro 64 bit et Windows 10 Pro 64 bit.
Bonsoir,

Oui mais là les mystères de l'informatique on connaît et on ne se pose plus trop de questions on y remédie :)

Perso, ça fait un moment que j'ai HTTP/2.

Comme j'ai vu le commentaire je pensais que tu avais un problème avec cette configuration.

:)
IP archivée
Amitiés et à bientôt...
Have a nice day...

alex

  • Administrateur
  • Dictionnaire ambulant
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 18.076
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #187 le: lundi 14 janvier 2019, 19:50 »
le: lundi 14 janvier 2019, 19:50

Non, non, je parlais juste du SSL automatique dans Wamp, vu qu'il y a énormément de personnes qui ne maitrisent pas du tout le truc. :)
 
IP archivée

JCFM

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.916
  • Choléra officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #188 le: lundi 14 janvier 2019, 19:58 »
le: lundi 14 janvier 2019, 19:58

Non, non, je parlais juste du SSL automatique dans Wamp, vu qu'il y a énormément de personnes qui ne maitrisent pas du tout le truc. :)
Bonsoir Maxi ! :ik:
Ab bon, tu crois ! lol :ih: ;D :hc:
IP archivée
Jean Claude :gt: Le "Choléra" officiel de chez Oim ! Alcoolique invétéré !

maximus23

  • Observateur
  • Pipelette invétérée
  • *******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 2.201
  • Grand chevalier du mot de passe
      • ®Smf® Solutions
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #189 le: lundi 14 janvier 2019, 20:04 »
le: lundi 14 janvier 2019, 20:04

Hello JCM :)
Non, non, je parlais juste du SSL automatique dans Wamp, vu qu'il y a énormément de personnes qui ne maitrisent pas du tout le truc.
Moi c'est suite au message que tu avais mis sur mon site concernant http/2 :)

Pour un SSL auto pas évident à faire ou faire un exécutable qui met tout en place en passant simple localhost en SSL car si on doit le faire sur des sites différents c'est pas gagné.

De plus cela peut-être fait en local en intranet ou en internet et c'est toutes des cfg différentes.

Sinon sur le site d'Artemus c'est bien expliqué pour le local.

De plus il faut apprendre un minima et savoir ce que l'on fait quand même ?

Enfin bref je ne vois pas de solutions simples.

:)
IP archivée
Amitiés et à bientôt...
Have a nice day...

Otomatic

  • Observateur
  • Grand orateur
  • ***
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 222
  • Vieux geek assagi
      • Aviatechno
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #190 le: mardi 15 janvier 2019, 09:34 »
le: mardi 15 janvier 2019, 09:34

Sinon sur le site d'Artemus c'est bien expliqué pour le local.
Mon “topo” précédent SSL/https en local est en partie basé sur celui d'Artemus24.

Quant à une procédure automatique pour SSL, il est impossible de pouvoir prendre en compte les configurations et dieu sait s'il y en a d'exotiques, de bancales, des qui tiennent avec des bouts de scotch, des jamais à jour, des qu'on sait même pas pourquoi elles tournent quand même, des modifiées avec des tutoriels qui datent de dix ou quinze ans et qui étaient pour W98 ou XP.

Et puis, je veux que l'utilisateur se responsabilise et fasse quelques efforts.  :jc:

Nota : Créer l'installeur complet Wampserver 3.1.7 m'a demandé cinq jours, 46 compilations et 46 installations en grandeur réelle plus deux vérifications finales sous W7 et deux autres sous W10. Mes quatre Wampserver sont des installations vierges 3.1.7
IP archivée
« La vie sans musique est tout simplement une erreur, une fatigue, un exil. » Friedrich Nietzsche.
« Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont forcément raison. » Coluche

maximus23

  • Observateur
  • Pipelette invétérée
  • *******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 2.201
  • Grand chevalier du mot de passe
      • ®Smf® Solutions
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #191 le: mardi 15 janvier 2019, 10:53 »
le: mardi 15 janvier 2019, 10:53

Et puis, je veux que l'utilisateur se responsabilise et fasse quelques efforts. 
Bonjour,

Je pense que WampServer est un outil ludique et didactique qui permet de faire connaissance avec toutes les bases d'un serveur.

Là on peut apprendre et faire ses propres expériences pour voir les tenant et les aboutissant de toutes les fonctionnalités présentes et pour les initiés on peut s'en servir comme mise au point de tests pour des configurations assez hard et des points de procédure et de sécurité.

Au moins on peut faire des erreurs sans gravité et faire en sorte d'y remédier même si on se casse les dents maintes fois ce n'est pas grave car comme on dit on apprend le plus de ses erreurs.

Enfin moi c'est ma façon de penser et de voir les choses.

Mais bon cela demande aussi un peu de bonne volonté car la plupart vont sur la facilité en demandant tout et n'importe quoi aux autres pour résoudre leurs problèmes même si ils ont les solutions sous leur nez dans les différents forum.

Cela leur fait perdre du temps car cela pourrait-être résolu par eux même avec un peu de lecture et de recherche at au moins ils auraient appris quelques corrections qui pourront leur servir à tout moment.

Quand on est en production réelle sur des sites importants il faut se dépatouiller de toutes sortes de choses bizarres maintenant la solution ultime est de payer pour une infogérance avec dévolution des droits !!!

:)
IP archivée
Amitiés et à bientôt...
Have a nice day...

JCFM

  • Observateur
  • Pipelette pathologique
  • ******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 1.916
  • Choléra officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #192 le: mardi 15 janvier 2019, 18:44 »
le: mardi 15 janvier 2019, 18:44

Et puis, je veux que l'utilisateur se responsabilise et fasse quelques efforts.  :jc:
Eh vlan, prends ça dans les dents, Jean-Claude ! :gk:

 :ij: Bonsoir Dominique !

Je ne peux vous donner tort !

Je fais amende honorable et je vais me mettre à la tâche quand j’en aurai fini avec un problème personnel qui me prend la tête depuis deux ans !

Je l'ai déjà signalé, je suis un cancre depuis tout petit, mais quand quelque chose me plaît, ou un secteur me fascine, j'ai l'avantage, sans me vanter, d'aller jusqu'au bout pour obtenir dans tous les cas ou toute situation 100 % de satisfaction.

Cordialement
Jean-Claude




Messages du même membre fusionnés car compris dans le délai d'édition. (Vous avez 30 minutes pour éditer)

Et puis, je veux que l'utilisateur se responsabilise et fasse quelques efforts. 
Bonjour,

Au moins on peut faire des erreurs sans gravité et faire en sorte d'y remédier même si on se casse les dents maintes fois ce n'est pas grave car comme on dit on apprend le plus de ses erreurs.

Enfin moi c'est ma façon de penser et de voir les choses.

:)
Bonsoir Maxi !
Bah oui et merci
IP archivée
Jean Claude :gt: Le "Choléra" officiel de chez Oim ! Alcoolique invétéré !

maximus23

  • Observateur
  • Pipelette invétérée
  • *******
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 2.201
  • Grand chevalier du mot de passe
      • ®Smf® Solutions
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #193 le: mardi 22 janvier 2019, 17:12 »
le: mardi 22 janvier 2019, 17:12

Bonjour,

Mise à jour d'Apache en 2.4.38 et pas de soucis rencontrés.

Reporté mes configurations http/2 SSL etc et tout fonctionne parfaitement.

On peut noter une nette amélioration sur le push du http/2.

Pour moi plus de bugs sur le changement de version Apache tout est nickel.

Toutes les autres mises à jour sont faites Php /MySQL/MariaDb et là pas le moindre soucis non plus.

Merci c'est impec :)
IP archivée
Amitiés et à bientôt...
Have a nice day...

alex

  • Administrateur
  • Dictionnaire ambulant
  • ********
  • Hors ligne Hors ligne
  • Sexe: Homme
  • Messages: 18.076
  • Proprio officiel chez oim !
Discussions autour de Wamp avec un de ses créateurs, Otomatic
« Réponse #194 le: mardi 22 janvier 2019, 18:59 »
le: mardi 22 janvier 2019, 18:59

Pour l'instant, je suis bien en 2.4.37 :)
On verra quand je mettrai à jour. Je le lirai le CHANGELOG chez Apache pour voir ce qu'il y a de neuf. ;)
IP archivée
Pages: 1 ... 10 11 12 [13] 14 15 16 ... 24   En haut
 

+ Réponse Rapide

Page générée en 0.182 secondes avec 26 requêtes.